server-config/hardware-configuration.nix

13 lines
280 B
Nix

{ modulesPath, ... }:
{
imports = [ "${modulesPath}/profiles/qemu-guest.nix" ];
boot.loader.grub.device = "/dev/vda";
fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
swapDevices = [
{
device = "/var/lib/swapfile";
size = 2*1024;
}
];
}