Browse Source

Require C++17 for optionals

search
Danila Fedorin 2 years ago
parent
commit
dd4aa6fb9d
  1. 4
      code/compiler/13/CMakeLists.txt

4
code/compiler/13/CMakeLists.txt

@ -1,6 +1,10 @@
cmake_minimum_required(VERSION 3.1)
project(compiler)
# We want C++17 for std::optional
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
# Find all the required packages
find_package(BISON)
find_package(FLEX)

Loading…
Cancel
Save